composer安装类库报错:it does not match the constraint

在PHP项目中Composer安装和加载第三方类库是很方便的方式,但是有时也难免出现一些错误令我们措手不及。

最近在一个项目中当我准备通过composer require安装一个微信的三方类库时,控制台报错:

Your requirements could not be resolved to an installable set of packages.

Problem 1
- topthink/think-installer v2.0.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.1.0] but it does not match the constraint.
- topthink/framework v5.1.41 requires topthink/think-installer 2.* -> satisfiable by topthink/think-installer[v2.0.0].
- topthink/framework is locked to version v5.1.41 and an update of this package was not requested.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

看了composer.lock文件,然后尝试把版本号修改为报错提示的版本号,没想到竟然不行。哈哈哈哈~

解决办法一共有两个,第一种办法就是解决依赖版本的冲突。我们可以通过执行以下命令:

  1. composer require composer-plugin-api:1.0

第二种办法就是通过忽略依赖进行安装。

  1. composer require zoujingli/wechat-developer --ignore-platform-reqs

看到如下截图,问题得以解决。

composer安装类库报错

 

波波
你想把广告放到这里吗?

发表评论

您必须 登录 才能发表留言!